algorithme


Guns'n'Roses Membre 161 messages
Forumeur inspiré‚ 28ans
Posté(e)

salut a tous!! je voudrai savoir un truc .bon quel est l'agorithme qui définie le maximum et le minimum de N nombre entier ??? merci d'avance

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Messages recommandés

boby77 Membre 23 479 messages
bob l'eponge en slip‚ 27ans
Posté(e)

c'est deja un nomdre N ;)

c'est pas un nombre entier?

Sinon le seul algoritme que je connaisse c'est l'algoritme d'euclide ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
Guns'n'Roses Membre 161 messages
Forumeur inspiré‚ 28ans
Posté(e)

atend je voulais dire N nombre entier c'est de (0 jusqu'a N)

Partager ce message


Lien à poster
Partager sur d’autres sites
Bashi VIP 5 233 messages
Just Breathe‚ 28ans
Posté(e)

Bah tu fais un tableau de N entrées,

Ensuite tu saisi en incrementant le tableau.

Et tu fais une boucle qui va de 0 ou 1 jusqu'a N entrées qui demande si le nombre saisi est superieur ou inferieur au nombre precedent.

Si il l'est tu le mets dans une variable "max" par exemple.

Si il ne l'est pas, tu le mets dans une variable "min" apres avoir fait un test de minima bien entendu ;) ...

J'espere que t'as compris ;) j'ai pas envie de te faire l'algo ^^

bashi

Partager ce message


Lien à poster
Partager sur d’autres sites
Guns'n'Roses Membre 161 messages
Forumeur inspiré‚ 28ans
Posté(e)

pour te dire j'ai fais ce que vous m'avais dis mais le 'min' afiche toujours 0 malgré que le 0 n'est pas saisie est ce que vous pouvez me signaler l'éreure??

Partager ce message


Lien à poster
Partager sur d’autres sites
Wild VIP 3 879 messages
Lonesome Cowboy‚ 32ans
Posté(e)

En admettant que tes nombres soient dans un tableau:

En pseudo code:

Initialisation des maxima et minima

Parcours du tableau et comparaison de chaque valeur avec minima et maxima

Remplacement si nécessaire

En algorithmique:

Programme max_min

constante N=10 // par exemple

variable

mini, maxi, indice: entier

tab: tableau [0..N] d'entiers // Le tableau des valeurs (on supposera qu'il est déja rempli)

debut

// Initialisation des valeurs avec la premiere valeur du tableau

mini <- maxi <- tab[0]

// Parcours du tableau

Pour indice=1 a N faire debut

Si ( tab[indice] < mini ) alors mini <- tab[indice]

Sinon Si ( tab[indice] > maxi ) alors maxi <- tab[indice]

FinPour

Fin

Wild

Ps: attention à nepas initialiser ton tableau à 0 mais à la premiere valeur de ton tableau

Partager ce message


Lien à poster
Partager sur d’autres sites
Bashi VIP 5 233 messages
Just Breathe‚ 28ans
Posté(e)

Pourquoi tu fais les devoirs Wild ;)

bashi ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
Wild VIP 3 879 messages
Lonesome Cowboy‚ 32ans
Posté(e)

Bah j'avais oublié que c'était aussi simple. ;)

J'aime beaucoup l'algo alors je me suis dit :" chouette je vais y reflechir un peu". Mais en fait c'était tout weak. ;)

Wild

Partager ce message


Lien à poster
Partager sur d’autres sites
Méthylbro VIP 1 038 messages
Ours des Pyrénées 100% AOC‚
Posté(e)

tsss ...

for ($i=0;$i<10;$i++) {
$entier[$i] = rand();
echo $entier[$i].'<br>';
}
// retourne dans un tableau le maximum et le minimum
// de la valeur passée en parametre :
function min_max($entier) {
	$result = array("min" => min($entier), "max" => max($entier));
	return $result;
}

$test = min_max($entier);
echo '<p>'.$test['min'].'<br>';
echo $test['max'].'</p>';
?>

bien sur ca, c'est en php. En réalité en Algorithme ca sera austre chose car, les fonction min() et max() n'existent pas ^^

alors vu que ce doit etre ca le sens de ton exercice, sache que tu peut te les faier toi même facilement, il s'agit juste de boucles ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
Wild VIP 3 879 messages
Lonesome Cowboy‚ 32ans
Posté(e)

uai mais ca c'est pas de l'algo, c'est du PHP. ;)

J'ai déja mis l'algo plus haut ;)

Wild

Partager ce message


Lien à poster
Partager sur d’autres sites
LaClandestina Membre 19 730 messages
Agent Publicitaire‚ 29ans
Posté(e)

oooo! ;)

Jsuis bien contente d'être en licence d'espagnol ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
Méthylbro VIP 1 038 messages
Ours des Pyrénées 100% AOC‚
Posté(e)

Wild, c'est pas un Algo ce que tu as fait ... Tu en veut de vrai Algo celon Kuntz ?!

bah CA, c'est un algo :

FONCTION MAX(entier VALEURS, entier NOMBRE)

 DEFINITION DES VARIABLES
entier i // compteur
entier result // resultat

 DEBUT

result <- 0

POUR i DE 1 A NOMBRE

  SI ( VALEURS[i] > result )
  ALORS
	result <- VALEURS[i]
  FINSI

FINPOUR

RETOURNER RESULT

 FIN


FONCTION MIN(entier VALEURS, entier NOMBRE)

 DEFINITION DES VARIABLES
entier i // compteur
entier result // resultat

 DEBUT

result <- MAX(VALEURS)

POUR i DE 1 A NOMBRE

  SI ( VALEURS[i] < result )	
  ALORS
	result <- VALEURS[i]
  FINSI

FINPOUR

RETOURNER RESULT

 FIN

ALGORITHME DEFINIR_MIN_ET_MAX 

 DEFINITION DES VARIABLES
entier i // compteur
entier VALEURS // différentes valeurs
booleen CONTINUE // teste de la boucle

 DEBUT

i <- 0
CONTINUE <- VRAI

TANT QUE CONTINUE

  AFFICHER "Entrer un entier :"
  SAISIR VALEURS[i]
  i <- i+1

  AFFICHER "Saisir un suivant ?"
  SAISIR CONTINUE


FIN TANT QUE

AFFICHER "Le minimum est :"
AFFICHER MIN(VALEURS,i)
AFFICHER "Le maximum est :"
AFFICHER MAX(VALEURS, i)

 FIN

Partager ce message


Lien à poster
Partager sur d’autres sites
Astrogirl Membre+ 1 307 messages
tchoubidouwap <3‚ 27ans
Posté(e)

;)

Bon, vous avez l'air de vous amuser, j'vous laisse ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant