Aller au contenu

Problème USB 3.0 - Le saviez vous ?


Messages recommandés

pep-psy Membre 23 228 messages
Forumeur alchimiste‚ 45ans
Posté(e)

Bonsoir,

C'est en faisant une manip ce soir, que je me suis rendu compte que l'USB 3.0 contenait une erreur que peu de personnes doivent connaître...

On a beau avoir une entrée USB 3.0 sur son PC et une bonne clé USB 3.0... Ce n'est pas pour autant que les transferts vont s'effectuer à pleine vitesse !!!

La faute à sa compatibilité descendante !!!

Lorsqu'on regarde les connecteurs de plus près... L'USB jusqu'à sa version 2.0 avec 4 pins, depuis la version 3.0, elle en a neuf !

Il fallait bien les caser quelque part, alors on a ajouté 5 petits carrés à l'entrée du connecteur femelle, celui que l'on retrouver sur nos PC

1773127215_USB3.0FemelleChassis.JPG.6ad9304024c8745f4832a697f202b5a3.JPG

Et sur le connecteur mâle, que l'on retrouve principalement sur nos clés USB (ou sur les câbles à brancher)

711931775_USB3_0Mle.JPG.7669f66aa0fcd4b30571a8455fef309d.JPG

On peut voir que d'abord on a les 4 pins de l'USB, puis les 5 petits doigts de l'USB 3.0

Le problème est que les 5 pins ne font pas toujours bien contact... Et que la clé va quand-même être reconnue et fonctionner, sauf que vous ne connaîtrez pas sa vitesse de fonctionnement !!!

Certains fabricants ont eu l'intelligence d'utiliser une LED de 2 couleurs, pour indiquer que l'on est soit en USB soit en USB 3.0, mais pas tous les fabricants ne la proposent.

On perd entre 5 à 10x (pour le standard 3.1) la vitesse de transfert, ce qui n'est pas rien !!!

Vous êtes prévenus !!!

;)

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant
bondgers Membre 1 197 messages
Forumeur alchimiste‚ 100ans
Posté(e)

Un problème qui devrait (j'espère) être résolu avec les connecteurs USB C

Partager ce message


Lien à poster
Partager sur d’autres sites
pep-psy Membre 23 228 messages
Forumeur alchimiste‚ 45ans
Posté(e)
Il y a 7 heures, bondgers a dit :

Un problème qui devrait (j'espère) être résolu avec les connecteurs USB C

Ben non, à moins que les PC en soient directement équipés !

Ce qui me dérange, avec l'USB C, c'est déjà l'escroquerie que pratique certains fabricants, dont Apple, qui laisse croire qu'il s'agit d'USB 3.1 et qui en fait ne sont que des 3.0 !

Le problème de ces normes, c'est que c'est la porte ouverte à n'importe quel escroc qui peut installer un tel connecteur tout en utilisant des puces mémoires qui ne sont même pas du niveau d'un USB 2.0 !

En plus, vu la puissance qu'est censé supporter l'USB C, je pense que les pistes vont rapidement se consumer au risque de brûler les pins !

C'est très fin comme pistes conductrices et pourtant c'est censé prendre beaucoup d'ampères !

Mais sinon, la norme USB C donc USB 3.1 est également compatible avec les normes précédentes !

Ce qui veut dire que l'USB 3.1 peut fonctionner sur un USB 2.0 et inversement, donc, si les 5 pins, ne touchent pas parfaitement, on passe en 2.0 !

Partager ce message


Lien à poster
Partager sur d’autres sites
garthriter Membre 331 messages
Forumeur survitaminé‚ 41ans
Posté(e)
il y a 18 minutes, pep-psy a dit :

Le problème de ces normes, c'est que c'est la porte ouverte à n'importe quel escroc qui peut installer un tel connecteur tout en utilisant des puces mémoires qui ne sont même pas du niveau d'un USB 2.0 !

Le problème de débit rencontré sur les périphériques usb 3 est plus lié à cela, qu'à une "compatibilité descendante" , un  problème de contact comme tu le mettais en avant dans ton premier message.

C'est par exemple le cas avec les clé usb Kingston "premier prix". Annoncés USB3, mais ont exactement le même débit que des clés usb2.

Et c'est pas la faute à un problème de connecteur, c'est juste qu'ils ont mis des puces merdiques.

 

Partager ce message


Lien à poster
Partager sur d’autres sites
pep-psy Membre 23 228 messages
Forumeur alchimiste‚ 45ans
Posté(e)
Il y a 12 heures, garthriter a dit :

Le problème de débit rencontré sur les périphériques usb 3 est plus lié à cela, qu'à une "compatibilité descendante" , un  problème de contact comme tu le mettais en avant dans ton premier message.

C'est par exemple le cas avec les clé usb Kingston "premier prix". Annoncés USB3, mais ont exactement le même débit que des clés usb2.

Et c'est pas la faute à un problème de connecteur, c'est juste qu'ils ont mis des puces merdiques.

 

Si j'en parle c'est parce que j'ai le cas sur une clé LEXAR qui est une marque professionnelle et un PC pro HP...

Quand j'ai lancé le transfert, je me suis dit que le temps annoncé ne correspondait pas et là j'ai vu que le transfert était sous la barre des 30Mo/s, donc j'ai stoppé, cliqué pour retirer la clé sans risque et je l'ai sortie pour la rebrancher !

Là on est passé à 150-100Mo/s !

Sur mon autre PC que je modifie et adapte, j'ai ajouté une carte PCI-E USB 3.0 avec 2 sorties arrières et 2 sorties intérieur, pour arriver en façade du PC

Les drivers font que cette carte à une séparation de reconnaissance entre USB 2.0 et USB 3.0, donc j'ai désactivé la partie USB 2.0 !

2021769137_USB2.0-3.0.png.5ae2cf6e2d942283877251fb7bd8b256.png

Quand une clé n'est pas visible dans le poste de travail, c'est qu'elle a été reconnue en USB 2.0 !

Et je peux te dire que cela arrive très souvent !

Je travaille avec 4 générations de Kingston, les Ultimate G, ainsi qu'un lecteur CF/SD de Lexar et cette fameuse clé Lexar, plus des DD externes qui eux ont la LED double couleur.

C'est normal que ça arrive, vu que les 5 pins sont vraiment tout au bord et qu'il faille enfoncer la clé vraiment tout au fond alors que la reconnaissance, par le PC se fait très rapidement !

Partager ce message


Lien à poster
Partager sur d’autres sites
garthriter Membre 331 messages
Forumeur survitaminé‚ 41ans
Posté(e)
il y a une heure, pep-psy a dit :

Si j'en parle c'est parce que j'ai le cas sur une clé LEXAR qui est une marque professionnelle et un PC pro HP...

Lexar a beau être une "marque professionnelle", toutes les marques font des clés "usb 3" bas de gamme.

Je viens de regarder des benchmarks et je vois par exemple que le Lexar JumpDrive S45 32 Go qui est pourtant estampillée USB3, fait un misérable 24 mo/s en écriture (source les numériques). J'ai des clés usb2 (pourtant bas de gamme) qui ne sont pas si loin, genre 17 mo/s.

En tout cas, ce n'est pas digne de s'appeler une clé usb3.

 

il y a une heure, pep-psy a dit :

Les drivers font que cette carte à une séparation de reconnaissance entre USB 2.0 et USB 3.0, donc j'ai désactivé la partie USB 2.0 !

:hum: Ca me paraît étrange. Je veux dire, l'USB3 étant rétrocompatible, il n'y a pas lieu d'afficher deux lignes dans le gestionnaire de périphériques.

 

il y a une heure, pep-psy a dit :

2021769137_USB2.0-3.0.png.5ae2cf6e2d942283877251fb7bd8b256.png

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
pep-psy Membre 23 228 messages
Forumeur alchimiste‚ 45ans
Posté(e)

Pour moi c'est une chance, je trouve cela bien de forcer le fonctionnement hardware qu'en USB 3.0, comme ça je suis certain que ce sera à la vitesse optimale !

Que Lexar propose des clés faiblardes, c'est possible, mais ma clé tourne à 80Mo/S en écriture, donc pas possible à atteindre en USB 2.0 !

Savais-tu, aussi, que la débit était divisé par le nombre de connecteurs USB 3.0 relié au chip qui gère la vitesse ?

Cela veut dire que si tu as un chip pour une sortie, elle devrait te permettre d'atteindre 600Mo/s au maximum !

Si tu en a 2 = 300Mo/s chacune au maximum

Si tu en a 4 = 150Mo/s chacune au maximum

Et c'est exactement ce qui m'arrive !

C'est quand-même con cette histoire !

Partager ce message


Lien à poster
Partager sur d’autres sites
Nephalion Modérateur 28 744 messages
A ghost in the shell‚ 42ans
Posté(e)

Ben que l'équipement ne fonctionne pas correctement si il n'est pas bien connecté, ce n'est pas non plus illogique.

Ca pourrait être pire, au lieu d'être considéré comme un périphérique USB2.0, il pourrait tout aussi bien ne pas être détecté par le PC.

A chacun de faire gaffe et de bien connecté l'équipement.

 

Pour ce qui est de la densité des connecteurs, c'est dans l'ère du temps, et depuis un moment déjà, de faire toujours plus petit.

Alors oui clairement ça pose des problèmes au fil du temps, quand les contacts s'usent.

On le voit avec certains connecteurs d'alimentations par exemple, qui finissent par faire des faux contacts ce qui parfois fait vieillir prématurément la batterie dont les cycles de charge sont ératiques.

Mais c'est une manière de faire marcher le commerce.

Parce que à bien y regarder, est-ce qu'on a vraiment besoin de faire des connecteurs toujours plus petits ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites
pep-psy Membre 23 228 messages
Forumeur alchimiste‚ 45ans
Posté(e)

Quand j'ai vu l'HDMI arriver, j'ai presque regretté la péritel !

Ils avaient presque eu l'idée d'y ajouter des vis, comme pour les connecteurs DVI / VGA, mais finalement, non, parce que c'était destiné au salon et non au bureau !

Le problème de l'USB 3.0, c'est que la clé est reconnue, mais pas forcément à la bonne vitesse !

C'est là que c'est problématique, parce que qui va s'en rendre compte ?

Un autre exemple, j'ai changé d'abonnement internet, je devais avoir une évolution du débit... Donc je me dis tout va bien et je lance un téléchargement et là je vois que la vitesse n'est pas cohérente, alors je lance un test de débit et là, je vois que je suis resté à la même vitesse qu'avant.

Alors j'appelle et je réclame et là on me dit que "non, nous avons pas de modification de contrat ?!"
(je devais payer le même prix, mais avoir une vitesse augmentée, mais en prenant un nouvel abonnement, l'ancien n'existant plus)

Top non ?

Toi qui connais un peu la technologie... Tu sais que les disques dur SATA sont désormais à la norme SATA 3, mais as-tu vu un seul disque dur lire ou écrire à la vitesse annoncée et supportée par le SATA 3 ?

:o°

J'adore la publicité à l'anglaise avec le "Up to" ... :lol:

Partager ce message


Lien à poster
Partager sur d’autres sites
Nephalion Modérateur 28 744 messages
A ghost in the shell‚ 42ans
Posté(e)

Ben les données annoncées le sont toujours pour un usage dans les conditions optimales d'utilisation, conditions qu'on ne trouve jamais au quotidien. :D

Les fabricants sous-estime l'usure de la connectique, qui en plus d'être mécaniquement fragile est parfois exposée aux conditions ambiantes. (poussière, humidité, utilisation un peu plus intensive qu'imaginée ...)

 

Chez un client j'avais installé un terminal tactile industriel qui vaut dans les 4k€.

Tous les jours un opérateur devait venir y mettre une clé USB pour récupération des données de production.

Ben on a a ajouté un cordon prolongateur USB pour que ce soit sur ce prolongateur que la clé soit branchée/débranchée afin de prolonger la durée de vie du connecteur USB du terminal.

C'est tout con, mais flinguer un appareil à 4k€ juste parce que le connecteur n'est pas vraiment industriel, ça la fout mal sinon.

 

Les débits annoncés, j'avoue ne jamais vérifier, faut dire que j'ai du mal à y croire.

Quand je vois qu'un PC sous Windows rame par moment alors qu'il n'y  a pas d'accès disque, peu d'accès mémoire, et que les différents coeurs du proc ne tournent à même pas 10%, ya de quoi se poser des questions... et douter de tout. :D

Partager ce message


Lien à poster
Partager sur d’autres sites
pep-psy Membre 23 228 messages
Forumeur alchimiste‚ 45ans
Posté(e)

Le coup de la rallonge USB ça fait longtemps que je pratique !!!

:D

T'es obligé !

Moi j'avais posé du matos dans une pharmacie et ils avaient sans arrêt des soucis avec ce qui s'appelle "la douchette" le pistolet pour les codes barres ... Mais quelle saloperie ce truc, comme ça faisait bouger le câble, il fallait sans arrêt, brancher/débrancher et parfois mettre un peu d'alcool sur le connecteur avant de le rebrancher !

Un truc à vouloir le souder directement sur la bête, d'autant que sur le câble y'avait encore un raccord...

Tout pour qu'un technicien soit appelé en renfort histoire qu'il puisse facturer sa venue...

:dry:

Pour les disques durs physique, faire déjà 150Mo/s ça me semble correct !

ça fait longtemps que je ne suis pas allé sur un site de bench pour voir si j'ai raison ou pas avec ces débits de données par DD physique connecté à du SATA 3.

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×

Information importante

Ce site internet utilise des cookies pour améliorer l'expérience utilisateur. En naviguant sur ce site vous acceptez que des cookies soient placés sur votre navigateur. Conditions d’utilisation