casse tête chinois


g_roseline Membre 205 messages
Forumeur activiste‚ 36ans
Posté(e)

Bon alors dans le genre casse tête chinois : sur mon site, tu est calé au pixel prêt...mais quand je navigue dessus avec IE, sur certaine pages j'ai un espace entre mon menu et mon bandeau...hors c'est juste incompréhensible : mes pages sont du copier-coller...il n'y a pas de différence...prenons un exemple concrêt : si je vais dans ma section Toulouse en français :

garonne-fr.png

tout va bien ! maintenant si je vais dans la même section en anglais :

garonne-en.png

pour plus de precision :

pixel.png

voila mon soucis......en faisant moults tests et vérification, j'ai réussit à isoler l'emplacement de l'erreur dans le code..si je remplace le bout de code de la version anglaise par lcelui de la version française..plus de soucis !!! Le truc c'est que je dois isoler la ligne exact de l'erreur afin de la modifier par chercher/remplacer sur tout le site !!!

Et voila mon probleme...impossible de voir la différence entre les deux...je l'ai meme imprimer et j'ai jouer au jeu des sept erreurs avec mon copain..a part le liens, rien d'autre (en tout cas si il y a qq chose je ne l'ai pas vu) n'est différent...alors, ça vous tente un jeu des sept erreurs ??

code de la version française qui fonctionne bien :

<!--tableau positionement au milieu de page--> 
<table width="100%" height="100%" border="0" align="center" cellpadding="0" cellspacing="0">
 <tr>
<td align="center" valign="middle">



<!--tableau "global"-->
<table  cellpadding="0" cellspacing="0" id="global">
<tr>
<!--cellule avec ombrage gauche-->
<td class="global_td_left"> </td>
<!--cellule de contenu-->
<td class="global_td_middle">



  <!-- tableau contenu-->
<table id="contenu" cellpadding="0" cellspacing="0">
<!--ligne du bandeau haut-->
  <tr>
  <td class="contenu_bandeau_td">	


<!--Tableau "logo"-->
<table id="logo" cellpadding="0" cellspacing="0">
<tr>
<td class="logo_td"><a href="../accueil/toulouse.php"><img src="../IMG/JPG/logo.jpg"></a></td>
 <td class="logo_icone_td">


<!--Tableau "icone"-->
<table id="icone" cellpadding="0" cellspacing="0">
<tr>
<td class="icone_home_td"><a  href="../../index.php"><img src="../../IMG/JPG/boutons/home.gif" width="16" height="16"></a></td>
</tr>
<tr>
<td class="icone_infos_td"><a href="#" onClick="MM_openBrWindow('fenetre-bord-garonne.html','','scrollbars=yes,width=300,height=300')"><img src="../../IMG/JPG/boutons/infos-pratiques.gif" width="16" height="16"></a></td>
 </tr>
 <tr>
  <td class="icone_forum_td"><a href="http://planete-photo.forumperso.com/index.htm" target="_blank"><img src="../../IMG/JPG/boutons/forum.gif" width="16" height="16"></a>


<!--fin tableau icone-->
</td>
</tr>
</table>

<!--fin tableau logo-->
</td>
</tr>
</table>

<!--fin ligne bandeau haut-->
</td>
   </tr>

<!--ligne menu dynamique-->
  <tr>
  <td class="contenu_menu_td">

et le code de la version anglaise qui déconne :

<body>

<!--tableau positionement au milieu de page--> 
<table width="100%" height="100%" border="0" align="center" cellpadding="0" cellspacing="0">
 <tr>
<td align="center" valign="middle">



<!--tableau "global"-->
<table  cellpadding="0" cellspacing="0" id="global">
<tr>
<!--cellule avec ombrage gauche-->
<td class="global_td_left"> </td>
<!--cellule de contenu-->
<td class="global_td_middle">



  <!-- tableau contenu-->
<table id="contenu" cellpadding="0" cellspacing="0">
<!--ligne du bandeau haut-->
  <tr>
  <td class="contenu_bandeau_td">	


<!--Tableau "logo"-->
<table id="logo" cellpadding="0" cellspacing="0">
<tr>
<td class="logo_td"><a href="../accueil/toulouse-EN.php"><img src="../IMG/JPG/logo.jpg"></a>
	</td>
  <td class="logo_icone_td">


<!--Tableau "icone"-->
<table id="icone" cellpadding="0" cellspacing="0">
<tr>
<td class="icone_home_td"><a  href="../../planete/accueil-EN.php"><img src="../../IMG/JPG/boutons/home.gif" width="16" height="16"></a></td>
</tr>
<tr>
<td class="icone_infos_td"><a href="#" onClick="MM_openBrWindow('fenetre-bord-garonne-EN.html','','scrollbars=yes,width=300,height=300')"><img src="../../IMG/JPG/boutons/infos-pratiques.gif" width="16" height="16"></a></td>
 </tr>
 <tr>
  <td class="icone_forum_td"><a href="http://planete-photo.forumperso.com/index.htm" target="_blank"><img src="../../IMG/JPG/boutons/forum.gif" width="16" height="16"></a>


<!--fin tableau icone-->
</td>
</tr>
</table>

<!--fin tableau logo-->
</td>
</tr>
</table>

<!--fin ligne bandeau haut-->
</td>
   </tr>

<!--ligne menu dynamique-->
  <tr>
  <td class="contenu_menu_td">

vous voyez une différence vous ???? :snif:

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Messages recommandés

g_roseline Membre 205 messages
Forumeur activiste‚ 36ans
Posté(e)

euh.......cherchez plus...j'ai trouvé......mais j'y comprend rien.....en fait le soucie c'était que c'était marqué :

<td class="logo_td"><a href="../accueil/toulouse-EN.php"><img src="../IMG/JPG/logo.jpg"></a>
	</td>

et l'erreur a disparu quand j'ai marqué ça :

<td class="logo_td"><a href="../accueil/toulouse-EN.php"><img src="../IMG/JPG/logo.jpg"></a></td>

Mais j'avoue n'y rien comprendre...on est bien d'accord non ? si je met <br> ça saute une ligne, mais par contre si je saute une ligne dans mon code ça ne change rien a ma page non ??? vraiment j'y comprend rien...j'en perd mon latin....

c'est moi qui suis cinglé ou cruche ? pitié dites moi que j'ai raison de ne rien y comprendre....

Partager ce message


Lien à poster
Partager sur d’autres sites
Kelevra Membre 365 messages
Forumeur survitaminé‚ 32ans
Posté(e)

Non t'es pas cinglé

Desfois faut pas chercher à comprendre...ca peut arriver par contre que le navigateur interprète une tabulation ou un truc dans le genre...

Pourquoi ? Le mieux c'est de ne pas chercher pour pas péter une durite

Partager ce message


Lien à poster
Partager sur d’autres sites
g_roseline Membre 205 messages
Forumeur activiste‚ 36ans
Posté(e)

merci...c'est soulageant de penser que je suis pas totallement folle....

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité benef
Invité benef Invités 0 message
Posté(e)

Les joies d'IE...

Partager ce message


Lien à poster
Partager sur d’autres sites
Tintagel Membre 499 messages
Forumeur survitaminé‚
Posté(e)

en HTML un retour à la ligne est considéré comme un espace, je pense que c'est de là que venait le problème

Partager ce message


Lien à poster
Partager sur d’autres sites
KelT Membre 1 855 messages
KelT Informatique‚ 26ans
Posté(e)

Salut, si IE t'embetes encore je te conseil mozilla :snif:ici

Modifié par KelT5362

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant