probleme en .css

Invité p-e
Invité p-e Invités 0 message
Posté(e)

voilà j'ai un problème en .css

mon fond d'ecran ne s'affiche pas sur mon site :smile2:

je vous met le bout de code:

h1

{

color:red;

font-size:26px

}

p

{

color:black;

font-family:"times new roman",arial,serif;

font-size:18px;

}

body

{

text-align:left;

background-image: url("site/matrix.jpg");

}

h1,p

{

text-align:left;

}

.element_menu

{

font-size:18px;

margin-bottom: 20px; /* Pour éviter que les éléments du menu ne soient trop collés */

}

#en_tete

{

width: 760px;

height: 100px;

background-image: url("banniere.jpg");

background-repeat: no-repeat;

margin-bottom: 10px;

}

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Messages recommandés

Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

Et si tu essayes ça -> background-image: url(site/matrix.jpg); ?

De même pour la bannière.

Modifié par Adenora

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité Crow
Invité Crow Invités 0 message
Posté(e)

J'y connais pas trop mais tu devrais avoir plutot

background-image: url(URL_PLUS_COMPLETE_banniere.jpg);

au lieu de simplement

background-image: url("banniere.jpg");

Modifié par Crow

Partager ce message


Lien à poster
Partager sur d’autres sites
Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

Il faut juste enlever les guillemets. :smile2:

Et mettre la bonne URL bien sûr. ;)

Modifié par Adenora

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité coeur bleu
Invité coeur bleu Invités 0 message
Posté(e)
Il faut juste enlever les guillemets. ;)

Et mettre la bonne URL bien sûr. ;)

chapeau bas! ;) c'est du latin pour moi,ces problèmes informatiques... ;) :smile2:

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

merci :smile2:

Partager ce message


Lien à poster
Partager sur d’autres sites
Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

De rien. :smile2:

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

ça marche pas :smile2:

moi je vais aller faire dodo je verrai ça demain...

Partager ce message


Lien à poster
Partager sur d’autres sites
Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

Je retente :

background: url(site/matrix.jpg);

J'ai enlevé le image derrière background.

éa fait un moment que je n'ai pas fait du CSS. :smile2:

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

ok j'essaye .;)

marche pô ,je crois que je vais aller dormir,sinon je vais me suicider à l'aide ma souris sans fil ;) .

surement à demain et merci pour votre aide! :smile2:

Partager ce message


Lien à poster
Partager sur d’autres sites
Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

Après être bien réveillé :smile2:

Ton background ne s'affiche pas, car l'URL vers l'image ne doit pas être bonne. Vérifie bien que matrix.jpg se situe dans le dossier site qui lui-même se situe au même endroit que ton fichier css.

Exemple d'arborescence :

- / (dossier racine)
index.html
design.css
- site (dossier site)
	  matrix.jpg

Modifié par Adenora

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

oui j'ai bien vérifié.

post-96314-1240909201_thumb.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

Il faut que tu mettes :

background: url(matrix.jpg);

Car l'image matrix.jpg se situe au même endroit que ton fichier design.css (comme banniere.jpg).

Modifié par Adenora

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

j'ai oublié de cacher les fichiers à gauche faites comme si il n'y avait rien :smile2:

Partager ce message


Lien à poster
Partager sur d’autres sites
ludo251069 Membre 1 472 messages
Forumeur alchimiste‚ 48ans
Posté(e)

il faut donner le chemin de l'image dans l'url !!! par défaut il prend en local et si il ne la trouve pas, elle ne s'affiche pas

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

ça marche pas je suis bon pour tout recommencer

:smile2:

comment tu as fait ta bannière?

Partager ce message


Lien à poster
Partager sur d’autres sites
Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

Euh, juste comme ça, enlève le .jpg derrière matrix.jpg dans ton dossier site (pas dans le code du design.css). Et retente.

Parce que j'ai l'impression que tu as mis une extension à ton fichier image, alors qu'il ne faut pas en mettre, car tu as caché les extensions dans tes paramètres.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

je crois que c'est ça j'eesaye

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité p-e
Invité p-e Invités 0 message
Posté(e)

que neni,c'est chiant à la fin.

je suis en train d'essayer avec une autre image ça me fait pareil.

je vais créer un "id" qui enveloppe "body".

et mettre le fond d'écran a cet id .

espérons :smile2: ...

marche pas non plus ça doit venir de l'adresse du fichier...

Partager ce message


Lien à poster
Partager sur d’autres sites
Adenora Membre 5 400 messages
Admiratrice de Scrat‚ 29ans
Posté(e)

Et quand tu affiches ton image en cliquant dessus, elle s'affiche bien ?

Je te présente un bout de mon design pour que ça te donne une idée :

body {
background: url(images/bg-contenu.jpg) repeat-y center;
text-align: center;
font: normal 80% "Trebuchet MS", Verdana, Arial, Helvetica, sans-serif;
color: #515151;
}

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant