Vista et Opengl


Invité MrLau
Invité MrLau Invités 0 message
Posté(e)

Bonjour,

Je suis loin d'être un spécialiste en informatique malgrés le fait que je suis à l'aise avec un ordinateur depuis pas mal de temps , mais là j'ai pas reussi a trouver mon bonheur sur le net en ce qui concerne Windows Vista et la gestion de l'opengl ...

Visiblement microsoft à décidé de privilégier son système de gestion 3D via DirectX au détriment de l'accélération Opengl ?

Perso, ca me dérange beaucoup car je pratique pas mal l'infographie 3D et la pluspart du temps l'accélération 3D du logiciel est géré via Opengl ... et le fait que Vista gère ca comme un grosse tache , ca me gache ma toute belle carte graphique :o

Quelqu'un aurait des infos à propos d'un éventuel correctif de l'intégration de Opengl dans Vista ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Annonces
Maintenant

Messages recommandés

tuotuo Membre 878 messages
Forumeur accro‚ 41ans
Posté(e)

Microsoft a du en effet se concentrer principalement sur DirectX 10, qui devait représenter une lourde tâche pour les devs.

De ce fait, il y a bien un support Opengl dans Vista mais les pilotes intégré à sa release n'était qu'en Opengl version 1.1 et celle-ci passait de plus par les routines de DX10 !

Pour que l'Opengl soit géré correctement par Vista, il est nécessaire aux fabricants de carte graphique de fournir des pilotes avec Opengl version 1.5 ou 2.0.

Essayes si tu ne l'as pas déjà fait de mettre à jour tes pilotes graphiques. Chez Nvidia, la version 158.18 semblent apporter un meilleur support de l'Opengl selon le Release Notes:

  • This driver supports the following 3D features:
    • Single GPU support
      • DirectX 9 support for GeForce 6/7/8 series GPUs
      • DirectX 10 support for GeForce 8 series GPUs
      • OpenGL support for GeForce 6/7/8 series GPUs

      [*]NVIDIA SLI support

      • DirectX 9 support for 6/7/8 series GPUs
      • OpenGL support for 6/7/8 series GPUs

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité MrLau
Invité MrLau Invités 0 message
Posté(e)

Merci pour l'explication :o

Bon malheureusement dans le PC portable c'est du ATI ( bah oui ... faut bien une faille quelque part :o ) ... une X1600 Mobility .... vais voir ce que ATI a fait coté drivers ( c'est pas gagné avec les drivers chez ATI en général :D )

Partager ce message


Lien à poster
Partager sur d’autres sites
tuotuo Membre 878 messages
Forumeur accro‚ 41ans
Posté(e)

Ah en effet, bonne chance avec les pilotes ATI et pour un portable en plus, argh :o

Eventuellement voir sur le site du fabricant du portable pour le pilotes mais tu risques d'avoir moins de chance que sur le site d'ATI :o

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant